Back to overview
Downtime
Financial API, Database Cluster, and 4 other services are down
May 10, 2026 at 9:40am UTC
Affected services
App Node 2
Secure Gateway
Financial API
Developer Documentation
Database Cluster
Data Ingestion Engine
Resolved
May 10, 2026 at 9:44am UTC
App Node 2, Secure Gateway, Financial API, and 3 other resources recovered.
Affected services
Created
May 10, 2026 at 9:40am UTC
App Node 2, Secure Gateway, Financial API, and 3 other resources went down.
Affected services